Resolved
The issue has been resolved and all functionality is restored. We’re sorry for any disruption caused.
Identified
We’ve traced the cause of the issue. It appears to be an issue with Amazon Web Services, which we use as an upstream provider.
Investigating
Some Handshaik customers may be experiencing problems at the moment. We’re investigating and working to restore full functionality as soon as possible.